Monday, April 27, 2009

Configurando el modem Tigo GBC en Ubuntu Intrepid Ibex

El problema es que Ubuntu lo detecta y configura como memoria USB y no como modem. Para este problema hay un programita llamado USB_modeswitch, que permite desmontar el USB y montar el dispositivo como Modem. La cuestion es llegar a la configuracion para Guatemala y tigo
POR FAVOR, LEAN TODO EL MANUAL ANTES DE HACERLO, YO SE PORQUE SE LOS DIGO.
Empecemos abriendo consola y damos un:
lsusb
mostrara algo como esto:
Bus 003 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 003: ID 0408:03ba Quanta Computer, Inc.
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 004: ID 138a:0001
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0951:1607 Kingston Technology Data Traveler 2.0
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 1c9e:6061
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

nos interesa la linea: Bus 002 Device 003: ID 1c9e:6061 esa es la informacion sobre el modem.

Luego veremos porque es tan importante.

Sigamos este link:
http://www.draisberghof.de/usb_modeswitch/#download

Nos hablan sobre una nueva version, pero lo que necesitamos es esto:
http://www.draisberghof.de/usb_modeswitch/usb_modeswitch-0.9.6.tar.bz2

tambien hay un .deb pero preferi hacerlo “a pie” todo para evitarme mas problemas-
Tambien bajamos un archivo de configuracion llamado usb_modeswitch.conf de aqui:
http://www.draisberghof.de/usb_modeswitch/usb_modeswitch.conf

ese archivo se descarga con click derecho y “Guardar enlace como” , ese archivo contiene la configuracion para muchos modems incluido el nuestro

El sitio dice que no olvidemos libusb pero en Intrepid no me hizo falta.

Descargados los archivos extraemos todo del paquete tar.bz2. Dentro hay varios archivos de texto y un solo binario ó ejecutable, llamado usb_modeswitch.

Tenemos que poner archivo binario en /usr/sbin

La forma mas facil es abrir la consola y poner:

sudo nautilus

pregunta contraseña de sistema y abre una ventana con permisos root.
Seguido de esto, creamos un archivo nuevo de texto y le escribimos este codigo:

#!/bin/sh
modprobe usbserial vendor=0x1c9e product=0x6061 && usb_modeswitch
sleep 3

lo guardamos con el nombre initmodem.sh, lo colocamos tambien dentro de /usr/sbin y le damos permiso de ejecucion.

Ahora ponemos una copia del archivo usb_modeswitch.conf en /etc

Como dije al principio sobre lsusb, lo que nos interesa es esto: ID 1c9e:6061

Con el archivo usb_modeswitch.conf puesto en /etc lo editamos y busquemos estas lineas:

########################################################
#Alcatel OT-X020 (aka MBD-100HU, aka Nuton 3.5G), works with Emobile D11LC
# Contributor: Aleksandar Samardzic
;DefaultVendor= 0x1c9e
;DefaultProduct= 0x1001
;TargetVendor= 0x1c9e
;TargetProduct= 0x6061
;MessageEndpoint=0x05
;MessageContent="55534243123456780000000000000606f50402527000000000000000000000"
########################################################

Vamos a quitar el # a la primera linea y luego quitamos los ; de las demas lineas para que quede asi:

########################################################
Alcatel OT-X020 (aka MBD-100HU, aka Nuton 3.5G), works with Emobile D11LC
# Contributor: Aleksandar Samardzic
DefaultVendor= 0x1c9e
DefaultProduct= 0x1001
TargetVendor= 0x1c9e
TargetProduct= 0x6061
MessageEndpoint=0x05
MessageContent="55534243123456780000000000000606f50402527000000000000000000000"
########################################################

Observando vemos que alli aparece la informacion que lsusb dio sobre nuestro modem. Guardamos y cerramos el archivo.

Ahora, atención aqui, vamos a configurar el archivo wvdial.conf tambien localizado en /etc
Ese archivo se encargara de conectarnos.

Abrimos el archivo, y reemplazamos todo lo escrito con esto:
[Dialer Defaults]
Phone = *99#
Username = guest
Password = guest
Modem = /dev/ttyACM0
Stupid Mode = 1
Dial Command = ATDT
[Dialer smartbro]
Init1 = ATZ
Init2 = ATE1
Init3 = AT+CGDCONT=1,"IP","broadband.tigo.gt","",0,0
Modem Type = USB Modem
ISDN = 0
Phone = *99#
Modem = /dev/ttyUSB0
New PPPD = yes
Baud = 912600
Idle Seconds = 3000
Auto DNS = 1
Stupid Mode = 1
Compuserve = 0
Dial Command = ATD
Ask Password = 0
FlowControl = NOFLOW

Guardamos y cerramos el archivo.

Recapitulando, tenemos el archivo binario y el archivo initmodem.sh en /usr/sbin y tenemos los archivos wvdial.conf y usb_modeswitch.conf en /etc

Conecten el modem y esperen a que ubuntu lo monte como USB, luego en consola ponemos:
sudo /usr/sbin/initmodem.sh

y debe aparecer un mensaje como este:

* usb_modeswitch: tool for controlling "flip flop" mode USB devices
* Version 0.9.6 (C) Josua Dietze 2009
* Works with libusb 0.1.12 and probably other versions
Looking for target devices
No target device found
Looking for default devices
Found default devices (1)
Prepare switching, accessing latest device
Looking for active default driver to detach it
OK, driver found ("usb-storage")
OK, Driver "usb-storage" successfully detached
Setting up communication with device
Trying to send the message
OK, message successfully sent.
-> See /proc/bus/usb/devices (or call lsusb) for changes. Bye

Esta indicando que lo encontro y ya lo monto como Modem
Y luego otra vez en consola ponemos:

sudo wvdial smartbro

y aparecera algo asi:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATE1
ATE1
OK
--> Sending: AT+CGDCONT=1,"IP","broadband.tigo.gt","",0,0
AT+CGDCONT=1,"IP","broadband.tigo.gt","",0,0
OK
--> Modem initialized.
--> Idle Seconds = 3000, disabling automatic reconnect.
--> Sending: ATD*99#
--> Waiting for carrier.
ATD*99#
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Mar 21 07:55:06 2009
--> Pid of pppd: 6085
--> pppd: h[08]�[08]
--> Using interface ppp0
--> pppd: h[08]�[08]
--> pppd: h[08]�[08]
--> pppd: h[08]�[08]
--> pppd: h[08]�[08]
--> pppd: h[08]�[08]
--> pppd: h[08]�[08]
--> local IP address 10.248.135.239
--> pppd: h[08]�[08]
--> remote IP address 10.64.64.64
--> pppd: h[08]�[08]
--> primary DNS address 200.49.160.31
--> pppd: h[08]�[08]
--> secondary DNS address 200.49.160.35
--> pppd: h[08]�[08]

Si todo fue como aqui ya tienen internet en su Ubuntu Intrepid.
Ahora, para aquellos que siguieron mi consejo de leer todo antes de intentarlo, aqui un regalo.
Entren a mi seccion de "Descargas", alli aparece una capeta llamada "modem tigo" y alli pongo a su disposicion los 4 archivos listos para funcionar, solo deben colocarlos en los lugares que el manual dice y ejecutan los codigos en consola para iniciar el modem.
Cualquier problema reinicien Ubuntu y ya.

22 comments:

Surizar said...

lo hubieras hecho al estilo poema, vos.

:D

Kalel said...

Gracias vos, solo una pregunta sera lo mismo para un modem zte mf626. gracias vos

Mario said...

¿pos onde están las Descargas?
y buen post ojala jale esa onda.

Joel DeVenney said...

Fijate que lo instale como dijistes pero no tengo ningun archivo ttyUSB* solamente archivos como estas: usbdev1.12_ep85

mi correo es jfreak53[at]gmail[dot]com

o aqui si fueras tan amable

Anonymous said...

que honda luis mi nombre es javier y solo deseo que me ayudes vivo en usa y le mande una laptop a mi hijo con win xp pero tengo problemas con el mismo modem que describis en tu blog porque si acepta el softwer pero luego le dice que la llamada no pudo ser completada que intente mas tarde y no puede conectarse a internet sera que hay alguna forma de alludarnos mi correo es allken31@hotmail.com

Onán Guerrero V. said...

Tienes la forma de hacer funcionar ese modem en Ubuntu 9.04???

He seguido tu guia en Ubuntu 9.04 pero no es igual.

Donde esta la sección de descargas?

fidel said...

para hacerlo en el 9.04 yo segui los mismos pasos y despues para facilitarlo cree con el editor de textos un archivo con estas lineas:

sudo modprobe usbserial vendor=0x1c9e product=0x6061
sudo /usr/sbin/usb_modeswitch
sudo wvdial smartbro

lo guarde en el escritorio como tigo.sh
luego clic derecho propiedades, despues en la solapa de permisos y le di permiso de ejecucion. ahora solo conecto el modem, una ves lo monta, doble clic en el archivo, me pide contraseña, y se cierra solo, luego le doy clic otra ves y listo ya esta conectado, si cierras el terminal se pierde la coneccion.

si alguien sabe de algun programa para poder medir la señal, se lo agradeceria.

Torch said...

hola trate de instalar el modem en un ubuntu 9.04 de la forma en que dijiste. pero simplemente no funciona habra alguna otra fomra de instalarlo?
gracias

Dennis said...

Luis, yo utilice el tutorial con un par de modificaciones, (otro modelo de modem en Tigo de Honduras) ejecuto el Wvdial y me conecto a Tigo, me asigna direccion IP, asigna la DNS local y remota, aparentemente todo bien, pero el firefox no carga las páginas ni el pidgin se conecta.

--> local IP address 10.247.104.234
--> pppd: x8�
--> remote IP address 10.64.64.64
--> pppd: x8�
--> primary DNS address 192.168.211.133
--> pppd: x8�
--> secondary DNS address 200.30.155.190
--> pppd: x8�

Que me hace falta configurar?

Luis Alvarado said...

@Dennis: estoy casi seguro que es problema del DNS, igual lo tuve yo con otro modem. Cambia el DNS y apunta a uno conocido, si no usa opendns y hace que estos sean tus dns por defecto.

WizarD said...

Saludos

Para el que lo necesite el ap en internet movil de claro es internet.ideasclaro

Mimer said...

@fidel fijate que he hecho lo mismo pero igual solo desaparece el modem y luego nada no me aparece en las conexiones como conectado simplemente no pasa nada :S en serio es importante saber configurar esto... se de mucha gente a quienes les interesa....

si alguien puede ayudarme nirris@gmail.com mi mail... gracias de antemano...

Luis Carlos said...

conio....ya probe como 5 veces...hasta me duele la shola...jajajaja...no puedo configurar esa onda mano...no kiero hacer a un lado mi ubuntu....alguien me puede explicar en español como lo hago...???

Luis Carlos said...

ya probe por 7a vez....y sigo en las mismas...solo me aumento el dolor de cojones...Luis Fernando, vivo en coban, cuanto me cobras por configurarme el modem..??? rios.luiscarlos@gmail.com

Eduardo Ralda said...

hola Luis soy novato en Linux quise empezar con el nuevo ubuntu 9.10 karmic koala pero tengo problemas con el mismo modem q tu describste intente hacer lo del tutorial pero cuando intento copiar el initmodem.sh en /usr/sbin me dice q no tengo permiso para hacerlo ya lo cree desde la consola y el mismo problema no puedo habilitar permiso de ejecucion dice que no soy el propietario espero me puedas ayudar de antemano muchas gracias elenano0989@hotmail.com!!!

Luis Alvarado said...

Según revise en la ultima versión de ubuntu, en la 9.10 ya no es necesario configurar de esta forma el módem, ya que ya trae soporte, lo único necesario es desmontar el módem y ponerle el AP en la parte de configuración.

Eduardo Ralda said...

oye pero me puedes decir como hago eso de ponerle el AP en la parte de configuración.

y disculpa mi ignorancia es que es la primera vez que utilizo UBUNTU y gracias de nuevo.

Anonymous said...

a chinnn no encuentro la seccion de descargas.. para bajar los archivos jajajajaja

El Dw@rf said...

Hey si fueras tan amable de hacer un post de como configurar el modem de Tigo para el ubuntu 9.10 ;) gracias

El Dw@rf said...

ahhh y donde rayos esta la seccion "Descargas" ??? :P

elbek said...

Señores señoras, esta manual fue lo primero que se hizo hace ya bastante tiempo y al tenerlo lfac me pidio permiso para publicarlo pero no estaba completo.
El manual terminado y las descargas estan en el sitio del grupo Linux de Amatitlan, en la seccion de manuales.

www.lugama.org

mono said...

mire mi amigo... fijese que ahorita acabo de instalar mi ubuntu 10.10, y sabes que me di cuenta... que la gui te lo configura automatico... :D jajajaja pero si... lo unico es que los modems huaweii no les gusta cambiar de hoyo USB, o sea son dongles de un solo hoyo... pirir ... tengo ambiente grafico en mi makina!! heeee!!! ahora hago point and click!